Announcement: iOS SDK deprecating support for iOS 9 and EOL support for iOS 8

Product(s)
Brightcove Player
Video Cloud
Role(s)
Device SDK Developer
Task(s)
Develop with the Native SDKs
Topic(s)
System Requirements
SDK
iOS
tvOS

The Brightcove Native Player SDK for iOS is deprecating support for iOS9, and as of January 1 2018, we will be removing support for iOS8.

Apple continually makes updates to its iOS operating system, which affects the technology that the Brightcove SDK is built around. In order to focus on cutting edge features, we must evolve alongside Apple by providing support for only the relevant versions of iOS.

Support for the Brightcove Native Player SDK for iOS is defined in terms of the major.minor.revision of an OS (for example: iOS 11.1.2). Only the latest revision of a version is supported. Customers can still use the Brightcove SDK for iOS on unsupported versions, however we provide no guarantee of functionality.

Data

Apple’s App Store

Apple’s App Store provides usage data that shows which iOS versions have logged into the App Store on a highlighted day. As of November 6th 2017, this data shows that 90% of devices connected to the App Store are running either iOS 11 or iOS 10. For current details, see Apple's App Store data.

 

App Store Statistics
Figure 1: App Store Statistics

 

Quick adoption by a considerably large percent of the market is a long running trend in the iOS market and is traditionally accelerated at the end of the year due to the holidays. Further historical data on adoption rates for new versions of iOS can be seen at mixpanel.com.

If you have any questions or concerns please do not hesitate to reach out to us through our developer forums, or through your account manager.