Troubleshooting Brightcove Gallery Issues

Product(s)
Gallery
Role(s)
Studio User
Topic(s)
Troubleshooting/Error Handling

In this topic you will learn how to troubleshoot the common issues customers have encountered when creating a Gallery Portal Experience.

Issues when configuring a site to use SSL

Requirements to configure a Gallery portal experience are outlined in the Securing a Video Site with SSL document. Common issues are listed here.

The keys were copied incorrectly

  • Make sure there are no white spaces around the values
  • Make sure the full key was copied. Make sure the ‘-----BEGIN CERTIFICATE-----’ and ‘-----END CERTIFICATE-----’ were included.
  • The public key should start and end with ‘-----BEGIN CERTIFICATE-----’ and ‘-----END CERTIFICATE-----’ respectively. The private key should start and end with ‘-----BEGIN RSA PRIVATE KEY-----’ and ‘-----END RSA PRIVATE KEY-----’
  • The certificate chain can have multiple concatenated keys

The key is not in PEM format

Check with the issuer of the certificates to make sure the key is in PEM format.

The key was self signed

Check with the issuer of the certificate.

The private key is password protected

We do not support password protected private keys. Non-password protected keys will look like:

-----BEGIN RSA PRIVATE KEY-----

MIIDXTCCAkWgAwIBAgIJAJC1HiIAZAiIMA0GCSqGSIb3DQEBBQUAMEUxCzAJBgNV BAYTAkFVMRMwEQYDVQQIDApTb21lLVN0YXRlMSEwHwYDVQQKDBhJbnRlcm5ldCBX aWRnaXRzIFB0eSBMdGQwHhcNMTExMjMxMDg1OTQ0WhcNMTIxMjMwMDg1OTQ0WjBF

.... MANY LINES LIKE THIS .... .... MANY LINES LIKE THIS ....

JjyzfN746vaInA1KxYEeI1Rx5KXY8zIdj6a7hhphpj2E04LDdw7r495dv3UgEgpR C3Fayua4DRHyZOLmlvQ6tIChY0ClXXuefbmVSDeUHwc8YufRAERp2GfQnL2JlPUL B7xxt8BVc69rLeHV15A0qyx77CLSj3tCx2IUXVqRs5mlSbq094NBxsauYcm0A6Jq
vA==

-----END RSA PRIVATE KEY-----

Password protected keys will look like:

-----BEGIN RSA PRIVATE KEY-----
Proc-Type: 4,ENCRYPTED
DEK-Info: DES-EDE3-CBC,91B305001070B5FD
MIIDXTCCAkWgAwIBAgIJAJC1HiIAZAiIMA0GCSqGSIb3DQEBBQUAMEUxCzAJBgNV BAYTAkFVMRMwEQYDVQQIDApTb21lLVN0YXRlMSEwHwYDVQQKDBhJbnRlcm5ldCBX aWRnaXRzIFB0eSBMdGQwHhcNMTExMjMxMDg1OTQ0WhcNMTIxMjMwMDg1OTQ0WjBF

.... MANY LINES LIKE THIS .... .... MANY LINES LIKE THIS ....

JjyzfN746vaInA1KxYEeI1Rx5KXY8zIdj6a7hhphpj2E04LDdw7r495dv3UgEgpR C3Fayua4DRHyZOLmlvQ6tIChY0ClXXuefbmVSDeUHwc8YufRAERp2GfQnL2JlPUL B7xxt8BVc69rLeHV15A0qyx77CLSj3tCx2IUXVqRs5mlSbq094NBxsauYcm0A6Jq
vA==
-----END RSA PRIVATE KEY-----

Incorrect line endings

If the key was transferred between a Linux and Windows machine, there is a very low chance that the line endings may have gotten corrupted. See this link for more information.

The public key and private key don’t match

This is a rare case. One way to check if a key matches is described in this link.

Contact Brightcove Support

If you are still having issues with configuring your Gallery site to use SSL, contact Brightcove Support. Please provide your Account ID, certificate issuer and the timeframe when you tried to upload the certificate.

Pages are showing up blank in Internet Explorer 9 and 10

The site should not be viewed using the Compatibility View mode in Internet Explorer. By default, Gallery pages load in "non-compatability" mode and should display correctly using IE 9 and 10. See Brightcove Gallery System Requirements for more information.

I made changes to my site but they don't appear

After you make changes to a Gallery experience, you must republish it before the changes will appear. Experiences that need to be republished will display a PUBLISH CHANGES link as part of the experience details. For more information, see Publishing changes to a site.

Note: You may also need to clear the browser cache and cookies if changes aren't appearing.

I enabled the social sharing options for the site but they don't appear

By default, the social sharing icons use a light color scheme and may be impossible or hard to see when your site also uses a light color scheme. For more information on how to change the icon color scheme, see the Customizing the Social Settings for a Portal Experience.

I selected the option to host on my own domain but I don't see my site

In order to host a site on your own domain, you have to add the domain as part of the Gallery settings, assign the domain as part of the site properties and and also add a CNAME record with your hosting provider. For more information, see Assigning a Custom Domain to a Portal Experience.

I updated the video title and/or description in Video Cloud but I don't see the update on my site

Gallery uses the Video Cloud CMS API to get video information. CMS API calls are cached to improve performance. It may take anywhere from 5 - 15 minutes before changes made to video metadata are reflected in the Gallery module.

I tagged a video (or updated custom fields, playlist, etc) and I don't see it when creating collections in Gallery

Gallery uses the Video Cloud CMS API to get video information. CMS API calls are cached to improve performance. It may take anywhere from 5 - 15 minutes before changes made to video metadata are reflected in the Gallery module.

When adding videos to collections, the wrong videos appear or no videos are added to the site

Check to make sure your Video Cloud account is enabled for HTTP delivery. We have seen strange issues when trying to add videos to collections when HTTP delivery is not enabled. The HTTP delivery setting is also required for the download video feature and for generating site maps.